Online Renewal System

System Requirements

This online system is fully supported by Microsoft Internet Explorer (except for 10 and greater), Mozilla Firefox and Netscape using 128-bit encryption.

If you are using Internet Explorer 10, you must be in “Compatibility Mode” in order to complete the transaction. You can switch to this mode by clicking the icon shown in the graphic below. Alternatively, you can select Tools from the menu and check “Compatibility Mode.”

Do not use Internet Explorer 11 as you will not be able to complete the transaction.

In order for payments to be processed successfully, licensees who are using Internet Explorer 11 will need to either roll back to Internet Explorer 10 or use Firefox to complete the transaction.

To see what version of Internet Explorer you are using, go to HELP in the Menu Bar and click on ABOUT INTERNET EXPLORER.

Close this window